Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
new version of mvoice
#11
Thanks Tom

I saw that you have solved the problem of the "Destination list" but now it does not allow me to select the "Setting" and "echo Test" buttons, perhaps having done "git pull" something has broken .... ..
Maurizio
Reply
#12
Sorry you're having so much trouble with mvoice, Maurizio.

If the Settings button is insensitive, then something is very broken, and I have no idea what has happened to your installation. It sounds like you need to start over again with a clean slate.

I also don't have any idea why your USB sound device is not working with mvoice. If you've installed pulse audio and "aplay -L" shows a "default" device at the beginning of the list, it should work. You might want to consider trying dudestar as it uses the qt audio package and mvoice uses alsa+pulse audio. Maybe dudestar will work better for you.
Reply
#13
I confirm Tom

I delete the directories "mvoice", "bin" and "etc", re-installed from scratch at the end with no error, when I go select the "Setting" button it goes into Block and I have to terminate the Process, mvoice [Not Responding]

Can you check this block?
Maurizio

(11-24-2020, 02:44 PM)n7tae Wrote: Sorry you're having so much trouble with mvoice, Maurizio.

If the Settings button is insensitive, then something is very broken, and I have no idea what has happened to your installation. It sounds like you need to start over again with a clean slate.

I also don't have any idea why your USB sound device is not working with mvoice. If you've installed pulse audio and "aplay -L" shows a "default" device at the beginning of the list, it should work. You might want to consider trying dudestar as it uses the qt audio package and mvoice uses alsa+pulse audio. Maybe dudestar will work better for you.

The USB board works and the result of my modulation I get by doing the Echo Test which is distorted and overmodulated by background noise as the conversion is squared

Maurizio
Reply
#14
Good morning Tom

I was able to understand the reason for my microphone because it had that strong buzz ... I had to connect the negative with the earth ground of my home, with this system the hum of 50Hz is gone, surely my station is very disturbed from various tools turned on, I have not yet read any answer from you, I hope I have not bothered you with my problems .. You have verified and found the problem of the "Setting" that makes the Mvoice block ... I would like to complete this your project !!

73, Mauritius
Reply
#15
Samplerate being 8000 s/s not supported properly by all motherboard soundcards.

In particular, my HP 4340 i3 laptop.

I've modified "mvoice" to do 48000 samples/sec, find the code on my website:
www (dot) unixservice (dot) com-au / parrot / src

BTW: This problem on Linux is not new, dating back to the early WSJT and WSPR days.
Reply
#16
Questions re "mvoice":

1) Is there a way to signal "mvoice" that PTT is pressed from another app?

2) Can "mvoice" signal that other process, audio is being received?

I'll attempt to code it myself, in the meanwhile.
Reply
#17
I'm lost in C++ programming, can somebody help?
I'm trying to use a semaphore to signal PTT has been pressed
and, to send back to my other process, audio is coming from the net.
I added "checkSem()" to MainWindow and want to call it from M17Gateway.process().
Here is my code so far.

mvoice342sem.tgz at:
www (dot) unixservice (dot) com-au / parrot / src
Reply
#18
Hello All,

I experimented a bit with M17 with a lot of plaesure
So here my configuration:
Computer board is a Orange Pi zero
Debian buster installed XCFE gui and tightvncserver, because no way to connect a screen directly
a micro/haedphone I use a plantronics blackwire m320 on the USB port.
The reflector is running and published when i look on the webpage https://reflectors.m17.link/admin
But the reflector is never shown up in the reflector list
The reflector is up and running during a good week, and reachable from the Netherlands where i made some test calls using mvoice

My question is how can i make that my refelctor is showing up in the list? without typing it in all the time i want to connect

Are there poeple out who were installing dudestar on debian? the executable on windoze is running, but i dont have a own windoze system...
Some informations howto would be appreciated
King regards

73's from Hans in Western France, Britanny
Kenavo!
Reply
#19
A new version of mvoice (210117) is available.

There are two major changes:
  1. There is no longer a dependency on sqlite3.
  2. M17 reflectors are now read from the new json file at [font=Droid Sans Mono", "monospace", monospace, "Droid Sans Fallback]https://reflectors.m17.link/ref-list/json[/font].
It's not a big deal, but try to make sure you do a "make clean" before you do a "git pull", otherwise you will leave a useless QnetDB.o file in your build directory:

cd mvoice
make clean
git pull
make install

You can also do "sudo apt remove libsqlite3-dev" if you don't have anything else that depends on sqlite3.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)